Trolling motor trips breaker when trying to use on max speed for long period - Page 2
Welcome guest, is this your first visit?
Page 2 of 2 FirstFirst 1 2
Results 11 to 12 of 12
  1. #11
    Member
    Join Date
    Oct 2014
    Location
    Helotes, TX
    Posts
    77
    Sounds like bad/dirty connection but could also be a breaker going out as someone already mentioned. Use a small wire brush and clean connections at the battery. Pull the main plug apart and inspect connections/clean them there. Inspect/clean connections on backside (Female end) of main wiring connection. If it still does it replace the breakers.
    Finch Nasty Bait Company Pro Staff www.finchnastybaitco.com
    Army Bass Anglers Coalition Pro Staff www.armybassanglers.com


    Bullet 20XD
    225 Merc/JSRE Modified ProMax

  2. #12
    Senior Member
    Join Date
    Mar 2008
    Location
    Hutto
    Posts
    4,993
    I'll just say that Jackie wasn't full of it when he told people not to run your TM on high across the lake. I have replaced lots of burned up parts inside those TM that have been abused.
    FearandLoathing likes this.

 

 
Page 2 of 2 FirstFirst 1 2

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. Minn Kota Max 65 Trolling Motor
    By Pivo in forum For Sale (Boats/Tackle/Etc)
    Replies: 8
    Last Post: 07-06-2016, 03:20 PM
  2. Minn Kota Max Pro 101 Trolling Motor
    By Pivo in forum For Sale (Boats/Tackle/Etc)
    Replies: 2
    Last Post: 04-24-2016, 06:53 AM
  3. Trolling speed question
    By Disinclined in forum Tips and Techniques
    Replies: 7
    Last Post: 02-08-2014, 08:06 PM
  4. Does propellor affect trolling speed?
    By Disinclined in forum Boats and Motors
    Replies: 2
    Last Post: 10-19-2013, 11:27 AM
  5. Trolling motor steering cable is to long
    By mlj381tx in forum Boats and Motors
    Replies: 0
    Last Post: 05-20-2013, 07:07 PM